留言板  |    文章总数=102  |    RSS订阅
毁灭友情的方式有许多,最彻底的一种是,借钱不还毒鸡汤

小白在OpenWrt/LEDE上安装ipk文件包和可用的V2Ray

2019-07-12     loonlog     120863     44

教小白怎样在OpenWrt或LEDE上安装ipk包,以可用的V2Ray为例子进行ipk安装包的使用方法。

我就是小白,初次接触OpenWrt和LEDE,苦于酷软中心么有我想要的插件,寻找很久,终于搞定,分享出来。

如果还没有梯子,可以看这个搭建V2Ray上网利器

(2020-6-3,最近,据说v2ray发现漏洞了,https://github.com/v2ray/v2ray-core/issues/2542#issuecomment-638264393  ,官方已更新版本解决问题,因此强烈建议,大家定期更新服务端和客户端的软件版本)

1、下载ipk安装包

去github搜索想要的安装包,比如这个链接https://github.com/kuoruan/openwrt-v2ray ,

image.png

两个都要下载,第二个链接是核心,第一个链接是配置界面和中文插件,先下载第一个如下图

image.png

再下载第二个,点击进入配置界面代码中心,然后点击下载,进入下载页面,如下两个图片

image.png

image.png


以上就把需要的文件给下载完了。


2、上传ipk文件包到lede系统文件夹tmp中

需要用到winscp工具,这大家自行下载

image.png

然后的界面大家就无比熟悉,就和win系统中文件夹的操作一样,进入系统文件夹,找到tmp,把上面第1步下载的3个文件拖入其中(注意别拖入文件夹中的文件夹,这个容易误动作)

loonlog-1.png


3、安装ipk包,很简单

利用xshell进入lede的ssh,方法见另外一篇博客(小白需要,我就是小白)

首先利用cd指令进入tmp文件夹,用ls指令查看tmp文件夹下的所有文件

loonlog-3.png

利用opkg install v2ray-core*指令进行安装,其中v2ray-core*为文件名,如下安装三个包的指令,一个一个的来

opkg install v2ray-core_4.19.1-2_x86_64.ipk
opkg install luci-app-v2ray_1.2.2-2_all.ipk
opkg install luci-i18n-v2ray-zh-cn_1.2.2-2_all.ipk

loonlog-4.png


ps黄色箭头标的,是我截图之前安装过,所以在运行安装指令提示的这个,新安装的话提示就是下面两条类似的,证明安装成功。


4、安装成功之后

浏览器输入Openwrt/LEDE路由器地址,进入左侧菜单“服务”,就看到下面的V2Ray了,进去之后,就是配置的过程了

loonlog-5.png


配置过程请看另外一篇文章:V2Ray for Openwrt 配置方法


官方资料:https://www.v2ray.com/chapter_02/01_overview.html


如果有酷软中心,那我们直接给lede一个离线安装包吧,直接安装使用,配置也简单,http://www.loonlog.com/2019/7/25/lede-v2ray-off-line/

有疑问的朋友,可以进行留言,请输入你们正确的邮箱地址,这样有人回复你的时候,你可以收到邮件通知,不然你可能就错失良机了呢,但是大家的留言邮箱不会被公开,放心使用!

软路由 , V2Ray , LEDE , OpenWrt

    觉得有用?请点击页面顶部广告支持我!

您可能感兴趣的文章

发表评论(关于评论)

评论列表,共 44 条评论

  • 回复

    30楼

    提示Unknown package 'v2ray-core-mini'怎么解决

    菜鸟之志 未知 ,

    回复

    你的软路由是什么平台,你下载的包不兼容吧,我不是很懂这个,你看下这个https://github.com/kuoruan/openwrt-v2ray/issues/5

  • 回复

    29楼

    安装完毕这三个ipk后 服务菜单栏出现V2Ray 但…………
    权限不足,无法读取UCI配置。

    求助~

    菜鸟之志 Matt ,

    回复

    这个需要有能力的网友回答,我对系统也不熟悉crying

    phantom Matt ,

    回复

    luci-app版本不对,V1.X和V2.X对应的openwrt版本不一样

  • sad

    回复

    28楼

    现在ss节点遇到特殊时期太容易封了,体验差,推荐个自用的V2ray和Trojan梯子,不容易封,还有不限流的IPLC线路,客服售后给力

     

    这里的链接被管理员删除了

     

    大家可以试试

  • 回复

    27楼

    安装这个文件的时候提示  缺少  resolveip , 怎么办?

    luci-app-v2ray_1.5.5-1_all.ipk

    菜鸟之志 dust ,

    回复

    这个问题我也搞不懂,让高手来回答把crying

    null dust ,

    回复

    直接opkg update,之后再装包就可以了

  • 回复

    26楼

    v2ray core安装包下载,根据CPU类型选择吗?A53四核RK3328,就选A53的那个文件吗?

    安装的时候,显示

    root@FriendlyWrt:~# opkg install v2ray-core_4.22.1-6_aarch64_cortex-a53.ipk

    Installing v2ray-core (4.22.1-6) to root...
    Configuring v2ray-core.

    Collected errors:
    * wfopen: /usr/bin/v2ray: Is a directory

    菜鸟之志 wanyj ,

    回复

    你这个问题我也不知道为啥,有以下几点怀疑:

    1、你的安装包在哪个文件夹,安装的时候,就进入这个文件夹安装,不知道你这个对不对,我对linux并不熟悉,我也是刚接触的laugh

    2、删除那个提示的v2ray文件夹,再来一次

    3、按照我文章里面说的,把包上传到tmp文件夹,进去这个文件夹安装。

    很想帮你,但我确实也是个小白

  • 回复

    25楼

    大佬能不能开一贴luci配置指南,或者你的配置方法。v2ray官网的代码形式和luci形式差别太大了,摸不到头脑啊

    菜鸟之志 yukine ,

    回复

    刚开始我也没搞定,然后我就用路lede的插件,最近我在研究研究再说

    yukine 菜鸟之志 ,

    回复

    发现我的问题了,我路由器是MIPS没开启fpu,重新编译固件加入fpu就正常了。至于luci配置,任意门加0.0.0.0监视ip好像就对了
  • Tak

    回复

    24楼

    只能lede用是吗

    我是openwrt

    菜鸟之志 Tak ,

    回复

    都一样的

  • 回复

    23楼
    目前,编译什么的我也没弄过,还是用的lede的插件,能满足我用,暂时也没有在深入研究,只等后续了。
  • 回复

    22楼
    楼主你好,我的软路由现在用的是最新原版OpenWrt,版本号v19.07.1,自己按照网上的教程编译出来的固件,遗憾的是,原版固件没有提供翻墙插件ipk软件包,ssr、v2ray都没有,不知道你这个方法适合给OpenWrt安装v2ray插件吗?可以加个微信探讨下嘛,QQ号就是我微信号
  • 回复

    21楼
    第一种用起来比较简单,第二种用起来比较爽,一个路由器过去了,所有设备都能过去,但是第二种并不复杂。本网站有教程可以满足你所有要求
  • 回复

    20楼
    你好: 我是2天前刚跨入门的小小白,看了很多文章,知识点很多有点找不到北了,来的目的就是为了翻墙,有2个问题我说的是否正确:一.购买Vultr服务器,之上安装V2Ray服务器,然后在自己电脑上安装V2RayN客户端,配置后可以就翻墙了? 二.自己搭建软路由(OpenWrt/LEDE),安装V2RAY插件,购买节点或代理地址(不懂艾),然后电脑上要安装(不装?)V2RayN客户端,可以就翻墙了? 是否第一种比较方便?第二种还要折腾光猫、无线路由器,怕搞不好连正常的网都上不去。 谢谢!
  • 回复

    19楼
    离线安装包好像有问题,订阅无法保存
  • 回复

    18楼
    里面很多地方,能打勾,或者能选的,都选一下,试试看,很多地方都可以试试
  • 回复

    17楼
    我在LEDE的酷软中心里配置好了V2RAY。代理运行状态也是双绿勾。但是电脑还是上不了googel. 我用WIN10的V2RAY客户端就能上。 为什么问题呢?
  • 回复

    16楼
    我在LEDE的酷软中心里配置好了V2RAY。代理运行状态也是双绿勾。但是电脑还是上不了googel.
  • 回复

    15楼
    想知道这个该怎么配置,配置完了都不能用,残念
    菜鸟之志 被玩坏的橙子 ,

    回复

    文章更新了,有配置教程,如果需要就来看看吧

  • 回复

    14楼
    V2Ray 文件有误,然后不知道怎么配置。emmm
  • 回复

    13楼
    已经弄好了,电脑重启之后就可以使用Xshell连接上了,现在已经安装好了,但是下一步v2ray配置,感觉毫无头绪,不知道从何入手了
    菜鸟之志 jane ,

    回复

    文章已经更新,增加了配置方法,如果还没搞定,来看看吧

  • 回复

    12楼
    哪一步出问题,怎么提示的呢
  • 回复

    11楼
    我前面都按照你的搞好了,但是利用xshell进入lede的ssh 这一步我始终进不去,一直是失败
  • 回复

    10楼
    kcptun我也没用过呢,没法帮助你,我也是菜鸟,😁
  • 回复

    9楼
    kcptun 安装ledeopen wrt tag备份软件。。我怎么按都是失误 。服务哪里没界面
  • 回复

    8楼
    离线安装包好像更新了,但是没有地方下,这个2.3.7似乎有点问题
  • 回复

    7楼
    目前这个确实太复杂,我也没搞定,暂时在文章下面给出了离线安装包,这个可以使用,且很容易配置,后续在研究一下这个,时间关系,这个要往后放一放了
  • 回复

    6楼
    按照你的教程装好之后,发现不会用。 不知道如何将v2ray的节点填上去,全局设置,入站,出站怎么填,能再出一个教程吗
    菜鸟之志 HONG CHANGMING ,

    回复

    教程已经出了,过来看看吧,有问题再交流

  • 回复

    5楼
    我也不知道后台怎么配置订阅,能在出个教程吗 ,全局设置,入站,出站具体怎么填的?
  • 回复

    4楼
    硬件斐讯K3,系统LEDE,按教程装好了v2ray和luci,但是从机场拿到的v2ray是订阅和vmess协议,不知道在这个后台怎么配置,请告知,谢谢。
    菜鸟之志 John ,

    回复

    写了篇配路由器v2ray的配置教程,过来看下是否能解决问题

  • 回复

    3楼
    以上1楼和2楼的回复,复杂的配置我也没搞定,那咱就用离线安装包使用另外一种方式吧http://www.loonlog.com/2019/7/25/lede-v2ray-off-line/
  • 回复

    2楼
    配置方法的链接失效了,按照你的方法安装成功了 但不会配置
    菜鸟之志 sankeg ,

    回复

    迟到的配置教程,看是否需要,入过你搞定了,来看看我设置的还有没有需要改进的地方吧

  • 111

    回复

    1楼
    感谢!按照你的方法安装成功了!